Page 1 of 1

CFFA3000 & Apple II+

PostPosted: Sat Oct 26, 2013 2:46 pm
by ktmchris

I am having issues with container corruption using an Apple II+.

CFFA 3000 latest firmware (v3.1)
SanDisk 256MB or USB
Slot 7, Emulating Slot 6.
16kb Language card, slot 0
No other cards

I have 2 Apple II+'s which react the same.

I create a 32MB container with any version of ProDOS 1.x.

Get into Dave shell and copy files to a new directory. After multiple copies, disk becomes corrupt.

Both machines have passed extensive runs of memory and system tests; including copy tests with real media.
I have a couple IIe's that pass any number of these copy tests with this particular CFFA3000 as well.

I think there is a bus timing issue with Apple II+.

Have you seen or solved a situation like this?

Chris V

Re: CFFA3000 & Apple II+

PostPosted: Thu Oct 31, 2013 2:53 pm
by david__schmidt
I was thinking maybe it was davex that was at fault, so I played around in an emulator with a 32MB virtual disk. No trouble there. As I prepare to try this at home, what can you tell me about:
1. Version of davex you have?
2. Are you booting from floppy, or something else?
3. Method of creating/formatting the blank 32MB image?
4. Files (or directories) that you copy once inside davex?
4.a. File sizes? Does it matter? How many files (typically) does it take?
4.b. Are you copying from 32MB to 32MB, or from floppy to 32MB?

To answer your question - I've used davex quite a bit, but I confess it's been on a GS and on a ///. No one (myself included) has seen any corruption happen so far.

Re: CFFA3000 & Apple II+

PostPosted: Thu Oct 31, 2013 5:20 pm
by david__schmidt
Ok, I just tried davex on a plain old Apple II+ with only a language card and the CFFA3000. Here are the tests I performed:

0. Booted from the davex 1.30 ( distribution floppy (using ProDOS 1.9)
1. Copied all files from the davex floppy to a 32MB disk, assigned to the SmartPort, created and formatted by CiderPress
2. Copied multiple files and subdirectories from the 32MB disk to the 32MB disk
3. Booted from the CFFA3000 into ProDOS and ran davex

No corruption so far... one thing that came to mind, though. Did you set the "autoboot older apples" to "yes" in the CFFA3000 configuration menu?