Potential Apple IIgs ROM 3 issue.

General forum for support issues related to the CFFA3000

Potential Apple IIgs ROM 3 issue.

Postby Lucyen » Thu May 29, 2014 4:14 pm

I beleive there might be a compatability issue with the Apple IIgs ROM 3. I beleive this might have to do with the expanded main board RAM, but I do not have the equipment (A IIgs ROM 1 or IIgs ROM 0) to test this with. Here's what I've done to knock on the problem though.

My normal operating configuration is the Apple IIgs ROM 3, with Slots 1-2 set to the defaults, Slots 5-7 set to "Your Card", the CFFA3000 in Slot 7, and an Apple IIgs Memory Expansion fitted with 1MB of memory. Starting out, my CFFA3000 firmware was v3.0.2. I have since upgraded to v3.1.

The problem first appeared as flakiness of native IIgs software. GS/OS runs normally, but some memory intensive applications cause a crash. Wolfenstein 3D and MODzap are the two that are flaky and will generally crash.

My first suspicion was the 1MB Apple memory epansion board. I removed this board, which made further testing impossible since both Wolfenstein and MODzap would run out of memory.

I downloaded disk images of both MMT, and the Apple IIgs Dealer Diagnostics (v3.0). I tried MMT first, but was disappointed that it only tests the memory expansion, and not the on-board RAM. It also indicated that the expansion board was fine. I then ran the Apple diagnostics, and the RAM came back fine. For kicks, I ran everything that didn't require loopback plugs. This is when things got strange -- it dropped to the monitor (star prompt) during the "Serial Internal" test, which exercises the Slot 1/Slot 2 serial port hardware. This was special in that a Control-OpenAfter that, I whittled down the test sequence to "Main Board RAM" then "Serial Internal", which crashes the system (drops to the monitor) reliably.

In the process of whittling, I removed the memory expansion board, set the slots to defaults, and then set them all to "Your Card" with the CFFA3000 in Slot 7. I also tried the CFFA3000 in Slot 1, set to "Your Card" with the same results.

At this point, I thought I might have bad main board RAM, despite getting passing marks. At this point I pulled an additional Apple IIgs ROM 3 from storage, installed the CFFA3000 in Slot 7, checked that this slot was set to "Your Card" and verified that it presented the same behavior.

Here's an example of the drop to monitor:

E1/4100: 00 58 BRK58
A=5800 X=1A02 Y=0000 S=01C4 D=0000 P=04 B=00 K=E1 M=00 Q=00 L=0 m=0 x=0 e=0

My new working theory was that I might have a bad disk image, or that the CFFA3000 was the source of the issue. I proceeded to attach an 800k drive, enable the controller, and copy the disk image to the 800k floppy. I pulled the CFFA3000, and booted from the floppy. The same test pattern no longer produced the error, nor did a full test.

Reinserting the CFFA3000, even unused, produced the error.

Anyone know what might be going on, or have any theories?

Posts: 3
Joined: Wed May 28, 2014 11:13 pm

Re: Potential Apple IIgs ROM 3 issue.

Postby Lucyen » Fri May 30, 2014 9:53 pm

After further experimentation, I've determined that the problem DOES NOT occur simply because the CFFA3000 card is installed. It's much more specific. The Apple IIgs Diagnostics must be run from the card.

The additional testing I have done is to boot 'Copy II Plus' from the CFFA3000 in Slot 7, then run the Apple IIgs Diagnostics 'DLOADER.SYSTEM' on exit, which does not produce the problem. If I boot from Copy II Plus on floppy (produced by using Copy II Plus to copy the CFFA3000 image to the floppy) and run the diagnostic program from the CFFA3000, it crashes.

I chose Copy II Plus because it boots ProDOS, and allows me to run another ProDOS based program on exit.

I've purchased a ROM 1 machine, and am waiting for it to arrive. When it arrives (Most likely on June 5th) I will do further tests to determine of this is specific to the ROM 3.
Posts: 3
Joined: Wed May 28, 2014 11:13 pm

Re: Potential Apple IIgs issue.

Postby Lucyen » Fri Jun 06, 2014 10:15 pm

After further testing in the Apple IIgs ROM 1, the problem still presents -- although instead of dumping to the Debugger/Mini-Assembler, the video kicks into LGR with a red border. Very strange.

Additionally, the serial port test fails because the test itself appears to load from disk. A Smart Port test instead of a Serial Port test after a Main Board RAM test causes the crash no matter where it's run from.

The crash does not occur during diagnostics if the IIgs switch on the CFFA3000 card is off; but it does occur on a Control-Open Apple-Reset. A couple of those resets seem to clear it up.

I've went the additional step of downloading the Apple IIe Dealer Daignostics v2.1 and running the Main Board RAM, 80 Col RAM, and Disk Card tests with no failures or unexpected behaviors whatsoever. Whatever this problem is, it most certainly does not affect the 8-Bit machines whatsoever.

So here are the facts as I currently know them:
+ When unknown memory addresses are written or accessed, further virtual disk access to the CFFA3000 card results in a system crash.
+ This only effects Apple IIgs machines
+ Both ROM 1 (256K) and ROM 3 (1.125M) systems are effected.

I've reached the end of what testing I can do. It would be nice if another Apple IIgs and CFFA3000 owner would run a similar test to see if their card/system behave in the same way.
Posts: 3
Joined: Wed May 28, 2014 11:13 pm

Re: Potential Apple IIgs ROM 3 issue.

Postby roughana » Sat Jul 05, 2014 7:45 am

I assume MMT is Mega Memory Tester http://apple2.info/downloads?dl_cat=6.
I found Apple IIGS Diagnostics 3.0 http://apple2online.com/web_documents/a2gsdiagnostics_v3.0.zip - but is this the software you were using?
Please provide the link to the Dealer Diagnostic software you are using to test with.
Posts: 15
Joined: Fri Apr 25, 2014 8:41 pm

Re: Potential Apple IIgs ROM 3 issue.

Postby roughana » Mon Jul 07, 2014 6:28 am

I can replicate a crash on a ROM1
Machine: ROM1 with CFFA3000 in slot 7 and RamGS 4MB in expansion memory slot - no other slots populated.

1. Loaded Apple Diagnostics 3.0 .2mg image into smartport on CFFA3000
2. Booted this image
3. Selected Main Ram test and Serial internal test
4. Executed selected tests
5. Machine 'crashed' when the serial test started. but not to monitor. Off into lala land. wiped screen etc

Hypothesis: the RAM diagnostic is killing a part of the CFFA3000 support in memory such that further use of the smartport is not possible.
Posts: 15
Joined: Fri Apr 25, 2014 8:41 pm

Return to CFFA3000 Support

Who is online

Users browsing this forum: No registered users and 1 guest