Alert: SanDisk 256MB CF cards does not work with V1.3 CPLD!

Post here if you have found compatibilty issues with a device you have tried with the CFFA Interface card. These can be accounts of both failure and success.

Moderator: rich

Alert: SanDisk 256MB CF cards does not work with V1.3 CPLD!

Postby rich » Fri Feb 25, 2005 4:35 pm

UPDATE: I have found a problem with v1.3 CPLD logic, that explains why these cards were not working. I will be sending out an email to all customers with more details.

Hi Everyone,

I just wanted to let everyone know that I recently bought 3 256MB SanDisk cards and none of them work with my CFFA card. I had never tried that card size, but always assumed that since the 64 and 128 and 1G cards all worked that the 256MB card would work also. It doesn't!
This problem appears to affect both v1.2 and v1.3 CPLD logic.

I am currently looking for the problem with my logic analyzer, but my time is so limited, all I can say for now is don't use that card. Sorry.

Also, I have never tried the 512MB card, so I can't tell you if that works or not. I will post a follow up when I find out what is wrong with the 256MB cards and my CFFA.
Last edited by rich on Sat Mar 12, 2005 2:15 pm, edited 2 times in total.
rich
 
Posts: 185
Joined: Sat Feb 16, 2002 6:00 pm
Location: Wisconsin

512 MB SanDisk works for me

Postby VegasA2 » Mon Feb 28, 2005 11:17 am

I have two CFFA cards (v1.3 firmware) both with 512 MB SanDisk cards. Except for an apparent incompatibility with the "superdrive" controller, I have had no trouble with either.
VegasA2
 
Posts: 4
Joined: Sun Jan 23, 2005 10:14 pm

Postby rich » Mon Feb 28, 2005 6:14 pm

Hi All...

I have found a serious problem with v1.3 CPLD logic that is currently shipping. Apparently in making improvments to v1.2 logic, I added some additional problems. These problems didn't show up on smaller devices, but were very apparent on the 256MB SanDisk card. I am testing a fix I made last night, and so far it looks very promising. The 256MB SanDisk card is working just fine now.
rich
 
Posts: 185
Joined: Sat Feb 16, 2002 6:00 pm
Location: Wisconsin

Alert: SanDisk 256MB CF cards does not work with V1.3 CPLD!

Postby rich » Mon Mar 21, 2005 8:41 pm

Hi All,

Well I was wrong about everything now working fine on the 256MB SanDisk cards. I am able to set up configurations were it fails consistantly with my latest logic. The problem relates to the number of other cards in the sytem, and it doesn't seem to matter what other cards they are. Just adding or removing a card will change the behavior of the 256MB CF card in the CFFA.
rich
 
Posts: 185
Joined: Sat Feb 16, 2002 6:00 pm
Location: Wisconsin

Postby rich » Fri May 13, 2005 9:56 pm

Just to follow up this thread....
The problem here is resolved with version 1.4 CPLD and the 3 jumper fix.
At first it appeared that I had fixed the problem with only a change to the CPLD, but that was only in my Apple IIgs. In my II+ and //e the addition of logic to latch the address lines and then use those latched versions via 3 jumpers was needed to get the CFFA card to work reliably with many CF cards.
rich
 
Posts: 185
Joined: Sat Feb 16, 2002 6:00 pm
Location: Wisconsin


Return to Compatibility Issues

Who is online

Users browsing this forum: No registered users and 1 guest

cron