Apple ][ Compatibility

Post here if you have found compatibilty issues with a device you have tried with the CFFA Interface card. These can be accounts of both failure and success.

Moderator: rich

Postby rsteinmetz70112 » Mon Mar 22, 2004 5:21 pm

Is the CFFA compatible with the Apple][? IF not why not. I saw a post that the CCFA uses 65C02 instructions, if and Apple ][ has a 65C02 ( Zip Chip ) would the CCFA work?
Posts: 11
Joined: Sun Mar 21, 2004 6:00 pm

Postby rich » Thu Mar 25, 2004 5:37 pm


In theory, you should be able to put a GTE 65SC02 in a II+ and dig up a copy of ProDOS before version 2.0, like 1.9 and it should work with my CFFA card. Now having said that, I just tried it with the two II+'s I have and I could not get it working. I know I had it working last year, but my main II+ has something wrong with the bus signalling. And the other II+ is one someone gave me and it needs some work. If anyone else has gotten this working, please let me know.

About the ZIP chip, I have never had a zip chip work in a II+ so I wouldn't bother trying that. Maybe its just my hardware, not sure.

The real problem with the II+ is its limited memory. Because my card only works with ProDOS and most ProDOS apps only run with a minimum of 128K, the II+ is really not very useful. Sorry.

<font size=-1>[ This Message was edited by: rich on 2004-03-25 17:39 ]</font>
Posts: 188
Joined: Sat Feb 16, 2002 6:00 pm
Location: Wisconsin

Postby rsteinmetz70112 » Wed Apr 28, 2004 3:23 pm

I got my CFFA put a 256mb SanDisk CF in and was able to format part of it on a Laser 128.

I tried the 8 drive setting but couldn't see 8 drives, I get 2 drives in Slot 5 and 2 in Slot2. What should I be getting?

I am not at the ProDOS limit. I have Slot 6 (which shows 2 drives but only really has 1), a Sider in slot 7 with 2 drives plus a ram drive in slot 3, that's a total of 5 so I should be able to see all 8 drives.

Am I doing something wrong?

I have tried moving it to my Apple][ but so far I am getting unreliable results. Sometimes I get a listing but sometimes I get an error.

I do have a ZipChip running in my ][, but I'm not sure its doing anything. I don't ant errors when running programs.
Posts: 11
Joined: Sun Mar 21, 2004 6:00 pm

Postby vbriel » Sun May 30, 2004 9:32 am

I have been able to test the new beta version of the firmware for the CFFA in my Apple IIplus and it has worked perfectly. The beta version firmware works with any II including models that have the 6502 in it. Rich has done a great job adjusting the timing issues to make it work. I've done pretty extensive testing and everything appears to work without error. I suggest talking with Rich if you want to use the CFFA in a II or IIplus.


Replica 1
The Apple 1 clone

<font size=-1>[ This Message was edited by: vbriel on 2004-05-30 10:33 ]</font>
Posts: 10
Joined: Sun Apr 11, 2004 6:00 pm

Return to Compatibility Issues

Who is online

Users browsing this forum: No registered users and 2 guests